Написать программу для поиска площади многоугольника с помощью Паскаля,срочно.

0 голосов
37 просмотров

Написать программу для поиска площади многоугольника с помощью Паскаля,срочно.


image

Информатика (14 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

Programm Ploshad;

Var S, a, R, r : real;

n: integer;

Begin

Write(' Задайте чило сторон n' );

Readln(n);

Write('Задайте сторону многоугольника a');

Readln(a);

Write('Задайте радиус описанной окружности R');

Readln(R);

Write('Задайте радиус вписанной окружности r');

Readln(r);

S=0.5*n*a*sqrt(sqr(R)-0.25*sqr(r));

Writeln('Площадь многоугольника S=',S);

End.

(1.4k баллов)