Всем привет! Кому не трудно, нужно выполнить данные программы в Паскаль и показать...

0 голосов
39 просмотров

Всем привет! Кому не трудно, нужно выполнить данные программы в Паскаль и показать результат. На компьютере. Пожалуйста, ерунду всякую не писать. Буду признателен) Желательно скриншот. Спасибо) Дам 40 баллов.Составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае:Сумма цифр данного трехзначного числа N является четным числом.Квадрат заданного трехзначного числа равен кубу суммы цифр этого числа.Треугольник со сторонами a, b, c является равнобедренным.


image
image
image

Информатика (296 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

подправил твою 1-ю программку. Тестил в ПаскальАБЦ но по идее работать должно в любом.

var

   num : integer;

   n1, n2, n3 : integer;

begin

   write('введите 3-значное число: ');

   readln(num);

   n1 := (num div 100);

   n2 := (num mod 100 div 10);

   n3 := (num mod 10);

   if (n1+n2+n3) mod 2 = 0

   then writeln('четное')

   else writeln('нечетное');

end.

хотя я эту программу сделал бы как нибудь так:

var

   num : integer;

begin

   write('введите 3-значное число: ');

   readln(num);

   if ((num div 100)+(num mod 100 div 10)+(num mod 10)) mod 2 = 0 then writeln('четное') else writeln('нечетное');

end.

на остальные программы сейчас времени нет... может если попозже...

(1.2k баллов)
0

Если не сложно, можете прислать скриншот, или написать, как пользоваться данной программой)

0

если у тебя тоже стоит АБЦ то все очень просто. Выделяешь текст программы в ответе и копируешь в среду программирования. Из за особенностей сайта он при этом зачем то добавляет между строками пустые строи (их можно убрать хоть они на работу программы и не влияют) и в конце строку с какой то фигней. Все что ниже "end." нужно удалить иначе будет ошибка.

0

Чтобы запустить программу на исполнение нужно либо нажать в меню "Программв=>Выполнить", либо на треугольник на панели, либо F9 на клавиатуре. После запуска программа предложит ввести 3-значное число. Набираешь его на клавиатуре и жмешь "Ентер". После этого строкой ниже программа напечатает слово "четное" если сумма цифр числа четная или "нечетное".

0

вторая программа должна быть полностью рабочей но строку "read(a, b, c);" лучше заменить на "readln(a, b, c);". На работу программы это никак не повлияет но так будет правильнее в данном случае.

0

возможность правки у меня уже пропала, поетому по третьей программе ошибки опишу тут на словах.

0

для начала read лучше поменять на readln это не ошибка но так лучше

0

парсинг цифр лучше сделать как я переделал для первой программы

0

для нахождения квадрата числа есть отдельная фенкция sqr(), поэтому лучше будет написать sqr(num) вместо умножения, хотя на результат это не повлияет

0

и в конце тебе нужно найти куб суммы цифр, а ты находишь сумму кубов цифр. Правильно будет (n1+n2+n3)*(n1+n2+n3)*(n1+n2+n3) но если у тебя ПаскальАБЦ то для этого тоже можно использовать функцию возведения числа в произвольную степень power(n1+n2+n3, 3)

0

Спасибо)