Составьте программу, которая вычисляет сумму чисел, больших a, меньших b, которые при...

0 голосов
45 просмотров

Составьте программу, которая вычисляет сумму чисел, больших a, меньших b, которые при делении на 3 дают остаток 1.var...begin writeln ('Введите a') readln... writeln ('Введите b') readln... for......end.ПРОШУ СРОЧНО К ЗАВТРАШНЕМУ ДНЮ. ДАЮ МНОГО БАЛЛОВ. Язык Паскаль


Информатика (14 баллов) | 45 просмотров
Дан 1 ответ
0 голосов

var a, b, s : integer;

begin

   writeln ('Введите a');

   readln(a);

   writeln ('Введите b');

   readln(b);

   for var i := a+1 to b-1 do if i mod 3 = 1 then s += i;

   writeln('сумма: ', s);

end.

(1.2k баллов)