Написать программу для решения системы линейных уравнений. (Программу надо написать **...

0 голосов
33 просмотров

Написать программу для решения системы линейных уравнений. (Программу надо написать на языке программирования в Паскаль Онлайн )


image

Информатика (48 баллов) | 33 просмотров
Дан 1 ответ
0 голосов

uses crt;

var

x, y, A1, A2, B1, B2, C1, C2:real;

begin

clrscr;

writeln('enter A1:');

writeln('enter A2:');

writeln('enter B1:');

writeln('enter B2:');

writeln('enter C1:');

writeln('enter C2:');

read(A1,A2,B1,B2,C1,C2);

if (A2 * B1 - A1 * B2) = 0 then

writeln('Программа не имеет решений')

else

   begin

   x:= (B1*C2-B2*C1) / (A2*B1-A1*B2);

   y:= (A2 * C1 - A1 * C2) / (A2 * B1 - A1 * B2);

   end;

writeln('x=', x:10:2);

writeln('y=', y:10:2);

end.

(18 баллов)
0

Спасибо! Вы можете подсказать - как вывести результаты программы?

0
0

по этой ссылке запуск программы в онлайн компиляторе