Напишите программу, которая выводит ** экран все цифры числа, начиная с первой.Входные...

0 голосов
294 просмотров

Напишите программу, которая выводит на экран все цифры числа, начиная с первой.Входные данныеВходная строка содержит натуральное число N .Выходные данныеПрограмма должна вывести все цифры введённого числа в одной строке, начиная с первой. Цифры отделяются пробелами.Примерывходные данные123выходные данные 1 2 3ТОЛЬКО ЧЕРЕЗ ПАСКАЛЬ АБС, без string. ЦИКЛЫ FOR, WHILEЕсли решение с интернета, то оно не засчитывается.


Информатика (120 баллов) | 294 просмотров
Дано ответов: 2
0 голосов

var N,t,k,N1:integer;

BEGIN

readln(N);

N1:=N;

k:=0;

while (N1 mod 10=0) do begin

k:=k+1;

N1:=N1 div 10;

end;

t:=0;

while N>0 do begin

t:=t*10 + (N mod 10);

N:=N div 10;

end;

while t>0 do begin

write(t mod 10,' ');

t:=t div 10;

end;

for N:=1 to k do

write('0 ');

end.

(1.4k баллов)
0

нет

0

Введи 310

0

у тя будет 3 1

0

Исправил, извините пожалуйста).

0

Спасибо!

0

если бы мог то и вам бы передал баллы

0 голосов

program Digits;

procedure foo(a: integer);

begin

 if a = 0 then exit

 else

   foo(a div 10);

 Print(a mod 10)

end;

var

 a: integer;

begin

 a := 12345;

 foo(a)

end.


image
(2.5k баллов)
0

begin var a := 123450; var n := 1; while n < a do n *= 10; while n <> 1 do begin n := n div 10; Print(a div n mod 10); end;end.

0

ого спасибо тебе

0

только тут ошибка, первый цикл нужно while n <= a do n*=10

0

помогите

0

пожалуйста

0

очень надо

0
0

Iolandavalerypad353

0

как же ты меня выручишь бро если поможешь

0

очень надо