Напишите программу ** языке Pascal. 1. Напишите программу. определяющую, сколько раз в...

0 голосов
50 просмотров

Напишите программу на языке Pascal. 1. Напишите программу. определяющую, сколько раз в число входит цифра. Цифра и число задаются пользователем в начале работы программы. 2. Напишите программу, определяющую, равна ли первая цифра числа его последней цифре. 3. Запишите алгоритм подсчета суммы, количества и произведения цифр произвольного целого положительного числа.


Информатика (42 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

1:

var N,k,s:integer;

BEGIN

s:=0;

readln(N,k);

N:=abs(N);

while N>0 do begin

if (N mod 10=k) then

s:=s+1;

N:=N div 10;

end;

writeln(s);

end.

2:

var N:integer;

s:string;

BEGIN

readln(N);

s:=IntToStr(N);

if (s[1]=s[Length(s)]) then

writeln('ДА') else

writeln('НЕТ');

end.

3:

var N,p,s,k:integer;

BEGIN

readln(N);

p:=1;

s:=0;

k:=0;

while N>0 do begin

p:=p*(N mod 10);

s:=s+(N mod 10);

k:=k+1;

N:=N div 10;

end;

writeln('Количество цифр = ',k);

writeln('Сумма цифр = ',s);

writeln('Произведение цифр = ',p);

end.

(1.4k баллов)
0

А если число трёхзначное?

0

А можно решить вторую задачу проще? Используя только тип integer?

0

Можно, но этот способ проще.