Паскаль абс.Составить программу для решения следующей задачи: Известный пират Флинт положил некоторую сумму S в банк под 3% годовых. Выведите на экран, через сколько лет сумма превысит 1,5S. Начальное значение S вводится с клавиатуры. Решать через while
program flint;
var s, s2, y: real;
begin;
readln(s);
s2 := s * 1.5;
while s < s2 do begin;
s := s * 1.03;
y := y + 1;
end;
writeln(y)
end.
Постарался)
Program n_1;
var s, m: real; n:integer;
begin
read(s);
n:=0; m:=s;
while (m<=1.5*s) do begin</p>
m:=m*1.03;
n:=n+1;
writeln(n);
Честно говоря, решение тут вообще не зависит от S. Всегда выводится одно и то же число - 14