Написать программу, которая будет определять сколько чисел делиться ** 3 без остатка **...

0 голосов
40 просмотров

Написать программу, которая будет определять сколько чисел делиться на 3 без остатка на диапозоне от n до k ​


Информатика (20 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

var

 sum, n, k, i: integer;

begin

 sum := 0;

 write('Введите n и k:');

 read(n, k);

 for i := n to k do

   if(i mod 3 = 0) then

     sum := sum + 1;

 write(sum);

end.

(276 баллов)
0

Спасибо.А чтр значит sum?

0

var count, n, k, i: integer;begin count := 0; write('Введите n и k:'); read(n, k); for i := n to k do if(i mod 3 = 0) then count := count + 1; write(count);end.

0

count - количество чисел

0

Спасибо

0

Известно, что "счастливый билет" в городском транспорте - это билет где сумма первых трёх и последних трёх цифр совпадает. Реализовать алгоритм, который позволяет по введенному номеру билета, определить - счастливый он или нет.Пример:Ввод: 026008 Вывод: счастливыйВвод: 126125 Вывод: несчастливый

0

Получилось что-то из того, что я выложила?

0

var num: integer;begin read(num); if((num div 100000 + num div 10000 mod 10 + num div 1000 mod 10) = (num div 100 mod 10 + num div 10 mod 10 + num mod 10)) then write('счастливый') else write('несчастливый');end.