Напишите, пожалуйста, ** питоне программу: ** вход программе подаются 2 целых числа n и m...

0 голосов
56 просмотров

Напишите, пожалуйста, на питоне программу: на вход программе подаются 2 целых числа n и m указывающие момент времени n часов и m минут. Определите наименьшее число полных минут через которое часовая и минутная стрелки расположатся на циферблате перпендикулярно друг другу.


Информатика (44 баллов) | 56 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

n,m=map(int,input('часы, минуты через пробел: ').split(' '))

n=n%12; cnt=0;

while True:

   m+=1; n+=m//60;

   m%=60; cnt+=1;

   k=n*5+m//12;

   if (m%12>5): k+=1;

   if (abs(k-m)==15) or (60-k+m==15): break

print(cnt)

>>>  

часы, минуты через пробел: 23 50

26

>>>  

часы, минуты через пробел: 20 53

7

>>>  

часы, минуты через пробел: 4 5

1

(9.7k баллов)