Составить программу к примеру. Z=maax(A,max(B+C,D+1)
var
a, b, c, d, z : integer;
begin
writeln('введите A B C D');
read(a);
read(b);
read(c);
read(d);
z := max(a, max(b+c, d+1));
writeln('z=', z);
end.