Составьте программу, используя подпрограмму (процедуру или функцию). В одномерном массиве...

0 голосов
79 просмотров

Составьте программу, используя подпрограмму (процедуру или функцию). В одномерном массиве случайных чисел MAS [1..15] вычислить произведение элементов, кратных 3.Это все нужно в Паскале.


Информатика (24 баллов) | 79 просмотров
0

Случайные числа из какого-то промежутка?

0

видимо да)

0

Для промежутка от 1 до 100 подойдёт?

0

да,конечно. Мне бы хоть какую нибудь прогоамму)

Дан 1 ответ
0 голосов

var mas:array [1..15] of integer;


i:integer;


k:biginteger;


function f(mas:integer):boolean;


begin


if (mas mod 3=0) then f:=True;


if (mas mod 3<>0) then f:=False;


end;


BEGIN


k:=1;


for i:=1 to 15 do begin


mas[i]:=random(100)+1;


write(mas[i],' ');


if (f(mas[i])=True) then k:=k*mas[i];


end;


writeln();


if (k=1) then writeln('Нет элементов, кратных 3') else


writeln(k);


end.

(1.4k баллов)
0

Благодарю