Составить программу к задаче: Сколько шансов при бросании трёх игральных костей выбросить...

0 голосов
51 просмотров

Составить программу к задаче: Сколько шансов при бросании трёх игральных костей выбросить x очков (от 3 до 18) и какие это варианты ( при помощи вложенный циклов). ПОМОГИТЕ ПОЖАЛУЙСТА Pascal abc


Информатика (12 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

var pk,vk,tk,x,k:integer;

begin

write('x = ');

readln(x);

for pk:= 1 to 6 do

begin

for vk:=1 to 6 do

begin

for tk:=1 to 6 do  

if pk+vk+tk=x then

begin

writeln('pk = ',pk,'   vk = ',vk,'   tk = ',tk,'   ',pk,' + ',vk,' + ',tk,' = ',pk+vk+tk);

k:=k+1

end

end

end;

writeln(k,' шансов')

end.

(1.7k баллов)