1)Составьте программу, выводящую на экран нечетные числа от 11 до 31.2)Составьте программу, выводящую на экран числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:1 1 1 2 4 8 ... 10 100 1000
Язык?
Что язык?
Ну на каком языке оно должно быть сделано? Паскаль, Питон, С/С++?
Паскаль
1) program znanija;
var
i,a: integer;
begin
a:=11;
for i:=1 to 10 do
a := a + 2;
writeln(a);
end;
end.
2) program znanija;
i,a,b: integer;
a := sqr(i);
b := i*i*i;
writeln(i, ' ', a, ' ', b);
Ой, в первом перед строчкой "for i:=1 to 10 do" добавьте "writeln(a);"
Номер 1
Program n_1;
var i:integer;
for i:=11 to 31 do if i mod 2 = 1 then write(i, ' ');
Номер 2
for i:=1 to 10 do writeln(i, ' ', i*i, ' ', i*i*i);