ПОМОГИТЕ С ИНФОРМАТИКОЙ!!!ОЧЕНЬ НУЖНО. Составьте программу: Дана таблица вещ таб B[1:7]....

0 голосов
54 просмотров

ПОМОГИТЕ С ИНФОРМАТИКОЙ!!!ОЧЕНЬ НУЖНО. Составьте программу: Дана таблица вещ таб B[1:7]. Замените каждый отрицательный элемент нулем. Дана таблица вещ таб С[1:10]. Найдите максимальный элемент таблицы.


Информатика (101 баллов) | 54 просмотров
0

Итак. Если требуется составить программу, то под таблицей подразумевается массив?А также данный массив каким образом вводятся числа? с клавиатуры?

0

да

Дан 1 ответ
0 голосов

Первая часть

Program n_1;

var i:integer; B: array[1..7] of real;

begin

   for i:=1 to 7 do begin

       read(B[i]);

       if B[i]<0 then B[i]:=0;</p>

   end;

   for i:=1 to 7 do write(B[i]:0:5, ' ');

end.

Вторая часть

Program n_2;

var i:integer; a:real; C: array[1..10] of real;

begin

   for i:=1 to 10 do begin

       read(C[i]);

   end;

   a:=C[1];

   for i:=1 to 10 do if (C[i]>a) then a:=C[i];

   writeln(a:0:10);

end.

(3.5k баллов)
0

СПАСИБО)))