Известны размеры комнаты: a-длина, b-ширина, h-высота. Составьте программу нахождения...

0 голосов
538 просмотров

Известны размеры комнаты: a-длина, b-ширина, h-высота. Составьте программу нахождения нахождения площади поверхности стен.Площадь окон и дверей не учитывать. Значения a,b,h ввести с клавиатуры ПАСКАЛЬ СРОЧНО


Информатика (24 баллов) | 538 просмотров
Дано ответов: 2
0 голосов

Program n_1;

var a, b, h, s1, s2:integer;

begin

   writeln('Введите длину, ширину и высоту комнаты');

   read(a, b, h);

   s1:=a*h;

   s2:=b*h;

   writeln('Площади 1 и 3 стены равны и равны ', s1, '. Площади 2 и 4 стены равны и равны ', s2);

end.

(3.5k баллов)
0 голосов

как вариант:


var

   a, b, h : integer;


begin

   a := readInteger('введите a = ');

   b := readInteger('введите b = ');

   h := readInteger('введите h = ');

   writeln('площадь поверхности стен равна ', 2*a*h+2*b*h);

end.

(1.2k баллов)