Дана строка заменить все вхождения "по" ** "под". Написать программу ** Паскале.

0 голосов
50 просмотров

Дана строка заменить все вхождения "по" на "под". Написать программу на Паскале.


Информатика (173 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Var s:string;i:integer;
begin
i:=1;
read(s);
while ibegin
if (s[i]='п') and (s[i+1]='о') then s:=copy(s,1,i+1)+'д'+copy(s,i+2,length(s)-i-1);
i:=i+1
end;
write(s)
end.

(8.5k баллов)