Напишите программу, которая по заданной дате определяет время года. Программа должна...

0 голосов
82 просмотров

Напишите программу, которая по заданной дате определяет время года. Программа должна проверять корректность введенной даты. Сделайте максимально просто, пж.


Информатика (30 баллов) | 82 просмотров
0

Дата какого формата?**.**.**** ?

0

да

Дан 1 ответ
0 голосов

C++(был использован std::scanf для облегчения работы.).

Compiler 7.3.0 GCC

#include

#include // for std::scanf.


int main()

{

   int D, M, Y;

   std::scanf("%d.%d.%d", &D, &M, &Y);

   if((D > 28 && M == 2) || M > 12 || (D > 31 && M != 2))

   {

       std::cout << "Неправильные данные." << std::endl;</p>

       return true;

   }

   if(M >= 9 && (M <= 11 && D < 31))</p>

       std::cout << "Осень" << std::endl;</p>

   else if(M == 12 && M == 1 && M == 2)

       std::cout << "Зима" << std::endl;</p>

   else if(M >= 3 && M <= 5)</p>

       std::cout << "Весна" << std::endl;</p>

   else if(M >= 6 && M <= 8)</p>

       std::cout << "Лето" << std::endl;</p>

   else

       std::cout << "Неопределенная дата." << std::endl;</p>

   return 0;

}


image
(4.0k баллов)
0

спасибо!!! Но мне надо на паскале я забыл указать

0

спасибо!!! Но мне надо на паскале я забыл указать