Напишите программу, которая выведет ** экран значение true или false, в зависимости от...

0 голосов
162 просмотров

Напишите программу, которая выведет на экран значение true или false, в зависимости от того, является ли введенное число х четырехзначным или нет.Пожалуйста сделайтеКому надо фото, 5 задание


image

Информатика (44 баллов) | 162 просмотров
0

язык?

0

var x: integer;a: boolean;beginwriteln('Введите число');read(x);a:=(x>999);writeln('Число четырёхзначное ',a);end.

Дан 1 ответ
0 голосов

procedure foo(n: integer; k: integer := 0);

begin

 if n = 0 then Print(k = 4)

 else foo(n div 10, k + 1)

end;

begin

 var N := ReadInteger();

 foo(N)

end.

(2.5k баллов)
0

PascalABC.NET