** вход программе подается количество битов.составьте программу ,которая переводит биты в...

0 голосов
60 просмотров

На вход программе подается количество битов.составьте программу ,которая переводит биты в байты ,килобайты,мегабайты,гигабайты.Заранее спасибо!)


Информатика (32 баллов) | 60 просмотров
Дан 1 ответ
0 голосов

Program bity;
var a, b, c, d, e: real;
begin
write ('Введите количество бит: ');
read (a);
b:=a/8;
c:=b/1024;
d:=c/1024;
e:=d/1024;
writeln ('Это столько байт: ', b:8:4);
writeln ('Это столько килобайт: ', c:8:4);
writeln ('Это столько мегабайт: ', d:8:4);
write ('Это столько гигабайт: ', e:8:4);
end.

(41 баллов)