Напишите программу для решения задач пользуйтесь операции div и mod дам 24 бала1.Задано...

0 голосов
51 просмотров

Напишите программу для решения задач пользуйтесь операции div и mod дам 24 бала1.Задано двузначное число. Найдите средняя арифметическая цифр числа2.Задано двузначное число. Найдите разность между количеством десятков и единиц3. Дана масса в граммах. Переведите её в килограммы и граммы4. площадь участка изменяется в арах. Найдите количество полных км в квадрате


Информатика (14 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

1)var
n:Integer;
a:array [1..10] of Integer;
begin
Read(n);
a[1]:=n mod 10;
n:=n div 10;
a[2]:=n mod 10;
Write((a[1]+a[2])/2);
end.
2) var
n:Integer;
a:array [1..10] of Integer;
begin
Read(n);
a[1]:=n mod 10;
n:=n div 10;
a[2]:=n mod 10;
Write(a[2]-a[1]);
end.
3) var
n,m:Integer;
begin
Read(n);
m:=n div 1000;
Write(m,'кг',' ',n-m*1000,'г' );
end.
4)var
n,m:Integer;
begin
Read(n);
m:=n div 10000;
Write(m,'километров квадратных');
end.

(100 баллов)