Дано натуральное число.Напишите программу,которая проверяет, является ли оно...

0 голосов
65 просмотров

Дано натуральное число.Напишите программу,которая проверяет, является ли оно четырехзначным и расположены ли его цифры в порядке убывания.


Информатика (654k баллов) | 65 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var

 n, i: Integer;

 s: string;

 isu: Boolean;

begin

 Write ('Введите число: ');

 Read (n);

 if (n >= 1000) and (n

   WriteLn ('Это число четырехзначное')

 else

   WriteLn ('Это число не четырехзначное');

 s := IntToStr (n);

 isu := True;

 for i := 1 to Length (s) - 1 do begin

   if s [i]

     isu := False;

     Break;

   end;

 end;

 WriteLn;

 if Isu then

   WriteLn ('Цифры расположены в порядке убывания')

 else

   WriteLn ('Цифры НЕ расположены в порядке убывания');

end.


(6.4k баллов)
0

Здравствуйте, можете пожалуйста помочь с информатикой? Программу надо написать в Кумире

0
0

К сожалению я в Кумире никогда не работал.

0

Очень жаль, но всё равно спасибо!