Напишите программу,которая заполняет массив из 20 элементов случайным числами ** отрезке...

0 голосов
898 просмотров

Напишите программу,которая заполняет массив из 20 элементов случайным числами на отрезке [10,100] и считает число пар соселних элементов сумма которых делится на 3


Информатика (23 баллов) | 898 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var


 A: array [1..20] of Integer;


 i, c: Integer;


begin


   Randomize;


   Writeln ('Массив случайных чисел:');


   for i := 1 to 20 do begin


     A [i] := Random (90) + 10;


     Write (IntToStr (A [i]) + ' ');


   end;


   for i := 2 to 20 do begin


     if (A [i] + A [i - 1]) mod 3 = 0 then


       Inc (c);


   end;


   Writeln;


   Writeln ('Число пар соседних элементов, сумма которых делится на 3 = ' + IntToStr (c));


end;

// ----------------- решение второй задачи ------------------------

var

 A: array [1..200] of Integer;

 i, c, s: Integer;

begin

   Write ('Введите количество чисел в последовательности: ');

   ReadLn (c);

   if c > 200 then begin

     Writeln ('Выберите количество чисел меньше 200!');

     Exit;

   end;

   for i := 1 to c do begin

     Write ('Введите ' + IntToStr (i) + ' число: ');

     ReadLn (A [i]);

   end;

   s := 0;

   for i := 1 to c do begin

     if (A [i] >= 400) and (A [i]

       s := s + A [i];

   end;

   Writeln;

   Writeln ('Cумма 3-х значных чисел, начинающихся на 4 = ' + IntToStr (s));

end;

(6.4k баллов)
0

Привет. Можешь решить задание по инфе в паскале?? Т.к. баллов у меня уже нету, могу скинуть 50 рублей на киви

0

Привет. А это и есть Паскаль. Баллы не нужны, денег не беру.

0

Напишите программу, которая в последовательности натуральных чиселопределяет сумму трёхзначных чисел, начинающихся на 4. Программаполучает на вход количество чисел в последовательности, а затем сами числа.В последовательности всегда имеется трёхзначное число, начинающееся на 4.Количество чисел не превышает 200. Введённые числа по модулю непревышают 10000.Программа должна вывести одно число: сумму трёхзначных чисел,начинающихся на 4

0

Сможете пожалуйста решить?

0

Сейчас сделаю...

0

Ок, спасибо вам большое

0

Решение добавил после ответа на 1-ю задачу.

0

Спасибо Вам большое!!! Дай Бог Вам здоровья