Задано трехзначное число, написать программу ** языке Паскаль, которая находит сумму его...

0 голосов
35 просмотров

Задано трехзначное число, написать программу на языке Паскаль, которая находит сумму его цифр и проверить четное оно или нет.


Информатика (34 баллов) | 35 просмотров
Дан 1 ответ
0 голосов

Program gt;
var s,q,n:integer;
begin
s:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
end;
writeln(s);
if(n mod 2=0)then writeln('четное')else writeln('не четное');
end.

(6.6k баллов)