PascalABC.net Составить программу проверки, попадает ли точка с заданными координатами x...

0 голосов
60 просмотров

PascalABC.net Составить программу проверки, попадает ли точка с заданными координатами x и y в закрашенную область (использовать формулы уравнения прямой, проходящей через две точки, и уравнения окружности).


image

Информатика (27 баллов) | 60 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var x,y: real;

begin

readln(x,y);

if (x>=-6)and(x<=-3)and(y>=-3)and(y<=2)or</p>

  (x>=-6)and(x<=-1)and(y>=2)and(y<=7)</p>

then writeln('Yes') else writeln('No');

end.

Пример:

-3 3

Yes

(194k баллов)
0

использовать формулы уравнения прямой, проходящей через две точки, и уравнения окружности

0

Вы на приведенном рисунке видите окружности? Или какие-то прямые кроме тех, что параллельны осям координат?