Помогите , пожалуйста, написать эту программу ** паскале , а то меня что-то в ступор...

0 голосов
58 просмотров

Помогите , пожалуйста, написать эту программу на паскале , а то меня что-то в ступор ввело , ведь программа , то легкая. Написать программу, определяющую сколько различных трехзначных чисел, содержащих только нечетные цифры содержится на отрезке от 100 до М (М< 1000).


Информатика (28 баллов) | 58 просмотров
Дано ответов: 2
0 голосов

var M,i,k:integer;


BEGIN

k:=0;


readln(M);


for i:=100 to M do


if ((i div 100) mod 2<>0) and ((i mod 10) mod 2<>0) and (((i div 10) mod 10) mod 2<>0) then


k:=k+1;


writeln(k);


end.

(1.4k баллов)
0 голосов

program chisla;

var


i, s, M: integer;


begin


writeln('Введите число, не превыщающие 1000');  

read(M);


s:=0;


 for i:=100 to M do


  if ((i div 100)mod 2 <>0) and ((i div 10 mod 10)mod 2 <>0) and ((i mod 10)mod 2 <>0) then


   begin


    write(i:4);


    s:=s+1;


   end;


writeln;


writeln('Чисел:',s);


end.

(12.2k баллов)