Написать программу ** Паскале, используя цикл. Нужно ввести число, и программа должна...

0 голосов
48 просмотров

Написать программу на Паскале, используя цикл. Нужно ввести число, и программа должна выдать количество цифр в введённом числе.


Информатика (132 баллов) | 48 просмотров
0

begin Print(ReadlnInteger('n =').ToString.Count)end.

Дано ответов: 2
0 голосов

var i,N,t:integer;

BEGIN

readln(N);

N:=abs(N);

t:=0;

while N>0 do begin

t+=1;

N:=N div(10);

end;

writeln(t);

end.

(1.4k баллов)
0 голосов

var

a, n: Integer;


begin

Read(a);

a := Abs (a);

repeat

a := a div 10;

n := n + 1;

until a = 0;

Write(n);

end.

(5.3k баллов)