Напишите программу ** Паскале для вычисления функции:50 БАЛЛОВ

0 голосов
23 просмотров

Напишите программу на Паскале для вычисления функции:50 БАЛЛОВ


image

Информатика (195 баллов) | 23 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var x,y: real;

begin

write('x = ');

readln(x);

if x<=0 then y:=-x</p>

else if x<=2 then y:=x</p>

    else if x<=4 then y:=4-x</p>

         else y:=x-4;

writeln('y = ',y:4:1);

end.

Пример:

x = 3

y =  1.0

(194k баллов)