Напишите программу, которая заполняет массив из 20 случайных элементов ** отрезке...

0 голосов
152 просмотров

Напишите программу, которая заполняет массив из 20 случайных элементов на отрезке [10;1000] и находит отдельно сумму элементов в первой и второй половинах массива.( На языке Паскаль, спасибо!)


Информатика (14 баллов) | 152 просмотров
Дан 1 ответ
0 голосов

var a : array [1..20] of integer;

i, s1, s2: integer;

begin

s1 := 0;

s2 := 0;

randomize;

for i := 1 to 20 do

begin

a[i] := random(991) + 10;

if (i < 11) then

s1 += a[i]

else

s2 += a[i];

end;

writeln(s1);

writeln(s2);

end.

(1.8k баллов)