Написать программу, которая выводит пример ** вычитание (в пределах 100), запрашивает...

0 голосов
227 просмотров

Написать программу, которая выводит пример на вычитание (в пределах 100), запрашивает ответ пользователя, проверяет ответ и выводит сообщение "Правильно!" или "Вы ошиблись" и правильный результат


Информатика (12 баллов) | 227 просмотров
Дан 1 ответ
0 голосов

program ProgramXY;
const n=100;

var inputText : integer;
begin  Randomize;

var x := Random(n) + 1;

var y := Random(n) + 1;

var z := x - y;

writeln('Решите пример: ', x, ' - ', y, ' = ');

readln(inputText);

if inputText = z then    writeln('Правильно!')

else    writeln('Вы ошиблись! Правильный ответ: ', z)

end.

 

Где-то так это выглядит на Паскале. Ошибки не обработаны, так что, если вместо числа ввести строку - программа умрет по исключению.

 

(218 баллов)