Уровень B. Напишите программу, которая заполняет массив из N = 10 элементов случайными...

0 голосов
591 просмотров

Уровень B. Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в диапазоне [-10,10], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу X. Программа должна вывести ответ «не найден», если в массиве таких элементов нет.Пример:Массив: -5 -6 2 3 -3 0 8 -3 0 9Что ищем: 0A[9] = 0на паскале(старая версия)


Информатика (54 баллов) | 591 просмотров
Дан 1 ответ
0 голосов

Примерно так:

program Poisk;

const

N = 10;

type

mas = array [-10..N] of integer;

var

a: mas;

x: integer;

i: integer;

begin

readln (x);

for i := 1 to x do

a[i] := random (10);

for i := 1 to x do

begin

if (a[i] = 0) then

writeln ('a',i,' := ',a[i])

else

writeln ('Такого индекса нету');

end;

end.

(60 баллов)