Написать программу если число чётное то делим ** 2 . Если ничтое то возводим В квадрат

0 голосов
34 просмотров

Написать программу если число чётное то делим на 2 . Если ничтое то возводим В квадрат


Информатика (18 баллов) | 34 просмотров
Дан 1 ответ
0 голосов

var a: integer;

begin

readln(a);

if a mod 2=0 then writeln (a/2)

else writeln (sqr(a));

end.

Программа представлена на языке Pascal.

(6.8k баллов)