Написать программу в паскале . Если число чётные то делим на два ,если нечётное то возвести в квадрат .
var a: integer;
begin
readln(a);
if a mod 2=0 then writeln (a/2) else writeln (sqr(a));
end.
Думаю, у Вас ошибка. Так как число нужно возвести в квадрат в случае, если оно нечётное, то нужно написать else weriteln (a*a)
Также "else..." нужно писать не с новой строчки
Также нет названия программы. Остальное всё идеально. Если это я что-то не так понял, скажите.
А, понятно, буду знать про sqr. Спасибо