Написать программу, которая проверяет, является ли целое число, введенное пользователем,...

0 голосов
50 просмотров

Написать программу, которая проверяет, является ли целое число, введенное пользователем, простым паскаль, цикл с постусловием


Информатика (754 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

program chet;

var i,k,n:integer;

begin

readln(n);

for i:=1 to n do

begin

if n mod i = 0 then k:=k+1;

end;

if k=2 then writeln('число,',n,',натуральное')

else writeln('число,',n,',не натуральное');

end.

(56 баллов)
0

спасибо,зайка