Помогите написать программу ** паскале: Даны 3 числа, если это куб-найти объём, если это...

0 голосов
13 просмотров

Помогите написать программу на паскале: Даны 3 числа, если это куб-найти объём, если это параллелепипед-найти площадь поверхности


Информатика (100 баллов) | 13 просмотров
Дан 1 ответ
0 голосов

var a,b,c,k: real;

begin

write('Введите 1 число: ');

readln(a);

write('Введите 2 число: ');

readln(b);

write('Введите 3 число: ');

readln(c);

if (a=b) and (b=c) and (a=c) then

begin

k:=a*b*c;

writeln('Объем куба равен ',k);

end else

begin

k:=2*(a*b+b*c+a*c);

writeln('Площадь поверхности параллелипипеда равна ',k);

end;

end.

(552 баллов)