Написать программу которая выясняет точка (x,y)заштрихованной фигуре c

0 голосов
41 просмотров

Написать программу которая выясняет точка (x,y)заштрихованной фигуре c0


image

Информатика (16 баллов) | 41 просмотров
0

срочно помогите решить!!!

Дан 1 ответ
0 голосов

var

 x, y, R, c: real;

begin

 c := 2; // тут задаётся радиус (на доске он вроде равен двум)

 Write('введите через пробел координаты x, y: ');

 Read(x, y);

 R := Sqrt(Sqr(x) + Sqr(y));

 if (c < R) and (x < 0) and (y > 0) then

   Write('точка принадлежит данной фигуре')

 else Write('точка не принадлежит данной фигуре');

end.


Второй скрин- показывает данную фигуру (заполнена случайными точками).


image
image
(5.3k баллов)