1. Напишите программу которая даст 12 слагаемых чисел из [-35..35] и вычислить их...

0 голосов
13 просмотров

1. Напишите программу которая даст 12 слагаемых чисел из [-35..35] и вычислить их сумму.2. Напишите программу, которая вычислить в байтах длину введённого текста.Срочно, пожалуйста!Паскаль


Информатика (12 баллов) | 13 просмотров
0

паскаль?

0

Да

Дан 1 ответ
0 голосов

Первая программа

var number, i, summa: integer;

begin

summa := 0;

randomize;

 for i := 0 to 12 do begin

   number := random(-35,35);

   writeln(number);

   summa := summa + number;

 end;

writeln(summa);

end.


Вторая программа

var text:string;

   i, len:integer;

begin

len := 0;

 readln(text);

 for i := 0 to length(text)-1 do begin

   len := len + 1;

 end;

 writeln(len*SizeOf(string));

end.


(3.4k баллов)