Задано целое число N написать программу которая находит количество 0 в заданном числе
//PascalABC.NET v3.3 1633
begin
var num:=ReadInteger('Введите число: ');
var sum:=0;
for var i:=1 to IntToStr(num).Length do
if IntToStr(num)[i] = '0' then sum += 1;
writeln('Количество нулей: '+sum);
end.
спасибо
Java: Scanner in = new Scanner(); String data = in.nextLine(); int counter =0; for(char g:data.toCharArray()){ if('0'.equals(g)){ counter++; } } System.out.println(counter);