Написать программу Дано натуральное число n Вычеслить...

0 голосов
22 просмотров

Написать программу Дано натуральное число n Вычеслить P=(1-1/2)*(1-1/4)*(1-1/6)*....*(1-1/(2*n))


Информатика (258 баллов) | 22 просмотров
Дан 1 ответ
0 голосов

Так как по условию дано число натуральное n, значит имеет смысл организовать вычисления с помощью цикла For.


//Pascal

var i,n:integer;

p:real;

begin

 readln(n);

 //так как находим произведение ряда,

 //то превый член ряда равен 1

 p:=1;

 for i:=1 to n do p:=p*(1-1/(2*i));

 writeln(p);

end.

(24 баллов)