Напишите программу,которая вычисляет среднюю за неделю температуру воздуха.Исходные...

0 голосов
428 просмотров

Напишите программу,которая вычисляет среднюю за неделю температуру воздуха.Исходные данные вводятся с клавиатуры.Пример входных данных.Понедельник>> 12Вторник>>10Среда>>16Четверг>>18Пятница>>17Суббота>>16Воскресенье>>14Пример выходных данныхСредняя температура за неделю: 14.71


Информатика (15 баллов) | 428 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var


 sum, temp, i: integer;


 sr: real;


 d_n: array[1..7] of string;


 


begin


 sum := 0;


 d_n[1] := 'Понедельник>>'; d_n[2] := 'Вторник>>'; d_n[3] := 'Среда>>'; d_n[4] := 'Четверг>>'; d_n[5] := 'Пятница>>'; d_n[6] := 'Суббота>>'; d_n[7] := 'Воскресенье>>';


 for i := 1 to 7 do


 begin


   write(d_n[i]);


   readln(temp);


   sum += temp;


 end;


 writeln(sum / 7);


end.

(574 баллов)