Составьте программу , которая формирует массив из 10 целых чисел Значения которых лежат в...

0 голосов
31 просмотров

Составьте программу , которая формирует массив из 10 целых чисел Значения которых лежат в интервале от - 10 до 10 ( [ 10:10] ) . Программа должна выводить на экран исходный массив затем преобразовать элементы массива , увеличивая в два раза положительные элементы , а для отрицательных элементы менять знак на противоположный . Выведите на экран преобразованный массив . В паскале abc!!!


Информатика (12 баллов) | 31 просмотров
0

От минус 10 до плюс 10?

Дан 1 ответ
0 голосов

const n=10;

var a:array[1..n] of integer;

i: integer;

begin

for i:=1 to n do

begin

a[i]:=random(21)-10;

write (a[i]:3,' ');

if a[i]>0 then a[i]:=a[i]*2;

if a[i]<0 then a[i]:=-a[i]</p>

end;

writeln;

for i:=1 to n do write (a[i]:3,' ')

end.

(1.7k баллов)
0

Нет... ))) Там обычно много писать надо... )))