Составьте программу, которая вычисляет средний балл по информатике в классе. Количество...

0 голосов
26 просмотров

Составьте программу, которая вычисляет средний балл по информатике в классе. Количество учеников и четвертные оценки каждого из них введите с клавиатуры


Информатика (16 баллов) | 26 просмотров
Дан 1 ответ
0 голосов

Pascal:

Var a,b,c,d:integer;

e:real;

begin

write('введите кол-во учеников -> ');

Readln(a);

For b:=1 to a do

Begin

Write('оценка ',b,' ученика');

Readln(c);

d:=d+c;

End;

E:=d/a;

Writeln('средний балл в классе', e);

end.

(24 баллов)