Написать программу. Даны 10 оценок ученика по математике. Найти средний бал. Исправить...

0 голосов
46 просмотров

Написать программу. Даны 10 оценок ученика по математике. Найти средний бал. Исправить оценки, которые <=3 на бал выше. Вывести все 10 оценок на экран.


Информатика (12 баллов) | 46 просмотров
Дан 1 ответ
0 голосов

java:

import java.util.Random;

int [] ocenki = new int [10];

Random rand = new Random ();

for( int i = 0; i < ocenki.length; i++){

   ocenki[i] = rand.nextInt(3+1) + 1;

   if (ocenki[i] <= 3) ocenki[i] = ocenki[i] + 1;</p>

   System.out.print(ocenki[i] + "\t");

}

(654k баллов)