Написать программу в pascal группа из 9 студентов сдала 2 экзамена по 2 предметам. оценки...

0 голосов
34 просмотров

Написать программу в pascal группа из 9 студентов сдала 2 экзамена по 2 предметам. оценки от 2 до 5. составить программу которая будет выводить эти сведения и будет показывать количество студентов имеющих СРЕДНИЙ балл меньше 3 по двум экзаменам


Информатика (22 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

const n=9;

var marks:array[1..n,1..2] of 2..5;

i,k:integer;

begin

writeln('Оценки студентов:');

for i:=1 to n do

begin

marks[i,1]:=random(4)+2;

marks[i,2]:=random(4)+2;

writeln(i,': ',marks[i,1]:3,marks[i,2]:3);

end;

k:=0;

for i:=1 to n do

if (marks[i,1]+marks[i,2])/2<3 then k:=k+1;</p>

writeln('Количество студентов, имеющих средний балл < 3 = ',k);

end.

Пример:

Оценки студентов:

1:   5  4

2:   5  4

3:   4  3

4:   5  5

5:   2  2

6:   2  3

7:   5  5

8:   3  4

9:   2  2

Количество студентов, имеющих средний балл < 3 = 3

(194k баллов)