Составить программу, которая формирует массив из 27 случайный чисел от -10 дл 15 и...

0 голосов
19 просмотров

Составить программу, которая формирует массив из 27 случайный чисел от -10 дл 15 и нечетные числа заменяет на 3, остальные уменьшает в 3 раза в паскале


Информатика (14 баллов) | 19 просмотров
Дано ответов: 2
0 голосов

const n=27;

var a:array [1..n] of integer;

i:integer;

begin

write('      Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(26)-10;

write(a[i]:3,' ');

if a[i] mod 2 <> 0 then a[i]:=3

else a[i]:=a[i]-3//уменьшает на 3,т.к. при уменьшении в 3 раза получается тип real, тут или второй массив создавать или взять a[i]:=a[i] div 3 (целочисленное деление)

end;

writeln;

write('Преобразованый массив: ');

for i:=1 to n do write(a[i]:3,' ')

end.

(1.7k баллов)
0 голосов

uses Arrays;

const

N = 27;

var

a : array of integer;

b : array of real;

i : integer;

begin

a := CreateRandomIntegerArray(N, -10, 15);

b := new real[N];

for i := 1 to N do

 if a[i-1] mod 2 = 1 then//[i-1] нумерация массива начинается

 b[i-1] := 3    // с нуля!

 else

 b[i-1] := a[i-1] / 3;

WriteLn('Исходный массив: ');

a.PrintLn;

WriteLn('Результат выполнения программы:');

for i := 1 to 27 do

 Write(B[i-1]:7:3, ', ');

 if i mod 6 = 0 then

 Writeln;

Writeln

end.



image
(5.6k баллов)