Паскаль срочно 90 баллов Уровень 9 класса 1.Напишите программу, которая в...

0 голосов
33 просмотров

Паскаль срочно 90 баллов Уровень 9 класса 1.Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа должна вывести одно число — максимальное число, кратное 4 2.Напишите программу, которая в последовательности натуральных чисел определяет кол-во чисел, кратных 4. Программа должна вывести количество чисел, кратных 4. 3.Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа должна вывести одно число — сумму чисел, оканчивающихся на 4


Информатика (14 баллов) | 33 просмотров
0

Как задаётся последовательность?

0

Не сказана

0

Т.е. можно сделать любым способом?

0

Чтобы было по схеме 9 классов

0

Это главное

0

У всех программы разные... )))

0

Могу сказать что тема: Короткий алгоритм на языке программирования

0

Три разные программы или всё это в одной?

0

Три разные

Дан 1 ответ
0 голосов

1.

var n,i,a,m:integer;

begin

m:=-1;

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число (больше -1): ');

readln(a);

if (a mod 4 = 0) and (a>m) then m:=a

end;

write('Максимальное число, кратное 4, равно ',m);

end.


2.

var n,i,a,k:integer;

begin

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число: ');

readln(a);

if a mod 4 = 0 then k:=k+1

end;

write('Количество чисел, кратных 4, равно ',k);

end.


3.

var n,i,a,s:integer;

begin

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число: ');

readln(a);

if a mod 10 = 4 then s:=s+a

end;

write('Сумма чисел, оканчивающихся на 4, равна ',s);

end.

(1.7k баллов)