Что-то подзабыл я pascal. Помогите написать программу в pascal, которая складывает...

0 голосов
63 просмотров

Что-то подзабыл я pascal. Помогите написать программу в pascal, которая складывает последние 4 цифры любого задаваемого числа.


Информатика (20 баллов) | 63 просмотров
Дан 1 ответ
0 голосов

Var a,s:integer;
begin
repeat readln(a) until a>9; // по условию число >9
s:=a mod 10; // забираем последнюю цифру
while a>9 do a:=a div 10; // вычеркиваем последнию цифру, пока а - двухзначное число
writeln(s+a mod 10) // теперь выводим сумму
end.

(45 баллов)
0

и в каком же месте тут сумма последних 4 цифр числа?

0

уже сам сообразил. ваша программа не корректна

0

это сумма первой и последе

0

а вопрос бы последние 4

0

насчёт последних не сообразила