Составьте программу, которая все числа кратные 10 делит ** 10 а остальные умножает ** 10....

0 голосов
127 просмотров

Составьте программу, которая все числа кратные 10 делит на 10 а остальные умножает на 10. ввод элементов массива либо с клавиатуры, либо случайным образом. количество элементов массива задайте самостоятельно. пожалуйста побыстрее


Информатика (22 баллов) | 127 просмотров
Дан 1 ответ
0 голосов

const n=10;

var i:integer;

a:array[1..n] of integer;

begin

for i:=1 to n do

begin

a[i]:=random(100);

write(a[i]:3,' ');

if a[i] mod 10 = 0 then a[i]:=a[i] div 10

else a[i]:=a[i]*10

end;

writeln;

for i:=1 to n do write(a[i]:3,' ')

end.

(1.7k баллов)