1) написать программу, которая считает сумму, в pascal abc 1+1/2+1/3+...+1/28, используя...

0 голосов
28 просмотров

1) написать программу, которая считает сумму, в pascal abc 1+1/2+1/3+...+1/28, используя цикл while2) написать программу, которая считает сумму, в pascal abc 1+1/2+2+1/3+3+1/4...+1/10+10, используя цикл while3) написать программу, которая считает сумму, в pascal abc 1-2+3-4+...-28, используя цикл whileрешите хотя бы две, пожалуйста


Информатика (390 баллов) | 28 просмотров
Дан 1 ответ
0 голосов

1)

var i,a:integer;

c:real;

begin

i:=1;

c:=0;

while i

c:=c+1/i;

i:=i+1;

end;

writeln(c);

end.

2)

var i,a:integer;

c:real;

begin

i:=2;

c:=1;

while i

c:=c+1/i+i;

i:=i+1;

end;

writeln(c);

end.

3)

var c,i:integer;

begin

c:=0;

i:=1;

while i

if i mod 2 = 1 then c:=c+i else c:=c-i;

i:=i+1;

end;

writeln(c);

end.

(162 баллов)