Информатика, ПАСКАЛЬ Напишите программу, перемещающую все нулевые элементы в конец...

0 голосов
19 просмотров

Информатика, ПАСКАЛЬ Напишите программу, перемещающую все нулевые элементы в конец массива 80 очков, помогите пожалуйста!!!!


Информатика (37 баллов) | 19 просмотров
Дан 1 ответ
0 голосов

const n = 10;

var

 mas: array [1..n] of integer;

 i,j,h:integer;

begin

randomize;

for i := 1 to n do

 begin

   mas[i] := random(3);

   write(' ',mas[i],' ');

 end;

 writeln();

for i := 1 to n - 1 do

 for j := 1 to n - i do

   if(mas[j] = 0) then

     begin

       h := mas[j];

       mas[j] := mas[j + 1];

       mas[j + 1] := h;

     end;

for i := 1 to n do

   write(' ',mas[i],' ');

end.

(1.4k баллов)
0

Спасибо)