Составьте программу, которая формирует массив из 15 случайных целых чисел от - 20до 20 и...

0 голосов
14 просмотров

Составьте программу, которая формирует массив из 15 случайных целых чисел от - 20до 20 и четные числа делит на 2, а нечетные умножает на 3


Информатика (12 баллов) | 14 просмотров
Дан 1 ответ
0 голосов

Program array15numbers;
var a:array [1..15] of integer; b:array [1..15] of real; i:integer;
begin
for i:=1 to 15 do
begin
a[i]:=-20 + Random(41); {почему не 40? такова особенность паскаля}
writeln(a[i]); {чтобы увидеть созданный массив}
end;
writeln(); {нужен, чтобы сделать отступ}
for i:=1 to 15 do
begin
if abs(a[i] mod 2) = 1 then {abs - модуль от числа, mod - остаток от деления}
begin
b[i]:=a[i]*3;
end
else
begin
b[i]:=a[i]/2;
end;
writeln(b[i]);
end;
end.

Остались вопросы? - спрашивай в комментах.
Нужно более подробное объяснение - пиши в лс vkcom/ilyahard

(216 баллов)